Problems getting eWeLink linked to Google Home

You are here:

Some people report troubles to relink their eWeLink account to Google Home. A message like Couldn't update the setting. Check your connection. will be displayed.

Below the left screenshot is taken by eWeLink Telegram group member Satyam (@sattybaba) and the right screenshot is taken by eWeLink Telegram group member Alexander (@alexander250100).

KB: Google Home linking issue (1)
KB: Google Home linking issue (2)

Preventing the need of relinking the eWeLink account to Google Home

At first often it is not necessary to relink your eWeLink account. Mostly it is done to get newly added devices to show up in Google Home. While eWeLink indeed explains in their documentation to remove and relink your eWeLink acoount to Google Home often it isn’t necessary.

Google Home has a great option to keep the devices in Google Home in sync with your your eWeLink account. There are several ways to do that:

  • Open the Google Home app and at the beginning screen of the app pull down to refresh. A round refresh icon will appear and will rotate when you release.
  • Hold the home button of your Android device (or manually open the Google Assistant and press the microphone button) and say “Hey Google. Synchronize my devices.”
  • Say to your Google Home / Google Home Mini / Google Nest mini / Google Nest hub: “Hey Google. Synchronize my devices.”

In all these 3 cases Google Home will fetch all device lists of all linked accounts and synchronize it to Google Home. Mostly this is done within half a minute but it depends on the amount of linked accounts and the amount of devices to synchronize.

Background of the issue

At this moment (March 31st, 2020) eWeLink is in touch with Google to solve this issue. eWeLink confirms this seems to be a bug on the side of Google:

The problem you mentioned was a known issue caused by a bug of Google home app. We have reported this bug to Google and hope they can fix it asap.

In the meanwhile, you are recommended to try the following methods to see if it works.

  1. Try to clear the cache of your Google home app and default browser.(Make sure you have backed up your important data)
  2. If you haven’t installed Chrome app on your smartphone. Please try to install one and set it as default browser and try to link with Google Home again.
  3. When the default browser is already Chrome but you still can’t link Google home, please check if the google home app your logged in in Chrome is same as the one in Google home.If not, change to the same account and try again.
  4. In case the method above fails, try to download Firefox app and set it as default browser and repeat step 3.
  5. If you are an Android user and happen to have an iPhone, please try to link on your iPhone.

When all the solutions above fail, please kindly wait until Google fixes this bug.

Source: eWeLink Telegram group

Workaround guides

Below are 2 good troubleshooting guidelines written by eWeLink Telegram group members but the first guideline below is eWeLink’s general guideline for this issue.

Caution!

It is recommended to skip this guideline and try Joennuh’s guideline below first!

Wordaround guide eWeLink

The problem you mentioned was a known issue caused by a bug of Google home app. We have reported this bug to Google and hope they can fix it asap.

In the meanwhile, you are recommended to try the following methods to see if it works.

  1. Try to clear the cache of your Google home app and default browser.(Make sure you have backed up your important data)
  2. If you haven’t installed Chrome app on your smartphone. Please try to install one and set it as default browser and try to link with Google Home again.
  3. When the default browser is already Chrome but you still can’t link Google home, please check if the google home app your logged in in Chrome is same as the one in Google home.If not, change to the same account and try again.
  4. In case the method above fails, try to download Firefox app and set it as default browser and repeat step 3.
  5. If you are an Android user and happen to have an iPhone, please try to link on your iPhone.

When all the solutions above fail, please kindly wait until Google fixes this bug.

Source: eWeLink Telegram group

Workaround guide Alexander

Alexander was the first one with the issue who have found a solution. He wrote the guideline below.

Caution!

It is recommended to skip this guideline and try Joennuh’s guideline below first!

First go to the internet and go to youre google account, then go to linked accounts. There you will see your Ewelink account, remove it. Strange thing is that it has been removed in Google Home app. Then I tried to reconnect but got same problems again.

Now to solve it make a new Ewelink account with the app on your phone, you have to remove the old one. Then remove the linked account from Ewelink again by internet not on the home app. Then connect youre new account to google home bij the app. Then i set my old account on a second phone and now I delete my ewelink modules one bij one and set them up in my new account.

A lot of work but the only solution

Source: eWeLink Telegram group

Good troubleshooting guides

After some research by Satyam he discovered that his RF bridge was causing the issue. Based on that there are 2 good troubleshooting guidelines which you could follow.

The first one is mine (Joennuh) and should be tried first since it saves you a lot of work when it helps:

Good troubleshooting guideline 1 (Joennuh’s workaround solution)

  • Remove the RF bridge(s) from your eWeLink account (be aware all attached settings and scenes will be removed too).
  • Synchronize devices to Google Home as per description above.
  • Add the RF bridge(s) again to your eWeLink account.
  • Synchronize devices again to Google Home.

Good troubleshooting guideline 2 (Satyam’s workaround solution)

This is the guideline Satyam provided after his research (it is copy/pasted without modifications):

I am facing this issue with ewelink since last month, ewelink was not syncimg with Google, so I unliked ewelink from Google, but I was uanble to link it back again. Today Mr. @alexander250100 gave me a tip about creating a new ewelink account.

So, here is what I did.

  1. First, I ensured that ewelink is completely unliked from my Google account by visiting the url myaccount.google.com/accountlinking and found that my ewelink is not linked, plan was to unlink it from there if it would have been there.
  2. Next, I created a new ewelink account and shared only one device from my old ewelink account to the new ewelink account.
  3. Next, I linked ewelink in Google app using my new ewelink account and it worked. I was able to see that one device in my Google app.
  4. Next, I kept on sharing devices one by one from my old ewelink account to new ewelink account, followed by asking Google Home to “Sync my devices” after each addition. I was able to add 36 devices and I had to repeat this process 36 times.
  5. Then, suddenly Google again gave me the same old error that it can’t sync ewelink. So I removed the last device that I added and Google worked again. I again added that device and I got the same error. And when I removed that device again, Google started working again. It was an RF Bridge.
  6. Then, I skipped that bridge and started sharing other remaining devices one by one followed by asking Google to “sync my devices”.
  7. Ultimately I managed to add all ewelink devices to Google except that bridge.
  8. Then I factory reset that bridge and added it to the new ewelink account and this time I was able to sync with Google without any problem. Finally, I added all my devices (50+).

Just wanted to share this with all of you so you can try this, as many people are struggling with this. I again want to thank Alexander for the tip, on which I improvised. jewel, please share this with your internal team and Google, so that it can help them in solving this issue permanently. This is in no way a good solution as it takes a lot of time and effort. Please let me know in case you have any question.

Source: eWeLink Telegram group

< Previous Translations
Next > When will widgets come back to the Android version of the eWeLink app?
Table of Contents

Contact

In case you think there is an error in a Knowledge Base article, there is something missing or when you have an idea for a new Knowledge Base article please contact us on our Contact form!

If you refer to an existing Knowledge Base article please include the link to the article involved!