iOS: Network name not prefilled during pairing, unable to send feedback and view in-app documentation

You are here:

On the latest iOS version (approximate iOS 15.2) you may experience that you are unable to pair new WiFi enabled devices because the feild for the network name (SSID) is not prefilled. When this happens you may also experience an error while sending feedback and while watching in-app documentation (Profile > Help & feedback and Message > Guide / Explore). If these symptons all occur at once on approximate iOS 15.2 you might be facing an enabled iOS privacy feature. With thanks to fellow community member Rahul Chavan on the official eWeLink Telegram group the community has found a workaround to these issues.

Information

The screenshots in this Knowledge Base article are provided by fellow community member Rahul Chavan, member of the oficial eWeLink Telegram group.

Below you see some examples of the issues you may experience within the same usage session.

No prefilled network name (SSID)

When during pairing you are asked to enter the WiFi password you see the network name (SSID) is not prefilled. Also the message During pairing your device, please enable your location permission is displayed right below the field for the network name (SSID).

You can not fill in the field manually. The eWeLink app should automatically detect to which network you are connected. If it fails to do so, the field for the network name (SSID) stays empty. Mostly this is caused by the lack of correct app permissions, but as we now discovered this can also be caused by iOS’ privacy settings for WiFi networks.

iOS pairing issue / SSID not prefilled: empty network name field
The field for the network name (SSID) stays empty
Error about the location permission is displayed

Errors while viewing in-app documentation and sending in-app feedback

It is also possible that you can’t view in-app documentation at these 3 spots within the app:

  • Message > Guide
  • Message > Explore
  • Profile > Help & feedback

You also might be unable to send in-app feedback as displayed on the example screenshot at the right.

iOS pairing issue / SSID not prefilled: unable to send feedback
Error when sending in-app feedback

The solution can rely in just configuring the app permissions correctly but if that doesn’t resolve these issues the iOS WiFi privacy settings also needs to be adjusted. Both are explained below.

Check app permissions

Step 1

  • Go to the iOS device settings screen.
iOS pairing issue / SSID not prefilled: iOS system settings

Step 2

  • Scroll down untill you see eWeLink.
  • Tap eWeLink.
iOS pairing issue / SSID not prefilled: eWeLink in app-list of iOS settings
Scroll down untill you see “eWeLink” and tap it

Step 3

  • Enable all app permissions.
  • Pay special attention to Location. Tap Location.
iOS pairing issue / SSID not prefilled: overview of app rights
Enable app permission
Enable app permission
Enable app permission
Tap “Location”

Step 4

eWeLink needs the app permission to fetch the currectly connected WiFi network.

  • Tap While Using the App. A will be placed at the end of this line.
iOS pairing issue / SSID not prefilled: location setting for eWeLink app
Tap “While Using the App”

Step 5

  • You can return to the homescreen.
  • Check whether pairing works normally and whether you can visit the CMS pages at Profile > Help & feedback and Message > Guide / Explore.
  • If the app does still not work correctly: proceed with the suggested solution below.

Disable iOS’ WiFi privacy features for the connected WiFi network

Step 1

  • Go to the iOS device settings screen.
  • Tap Wi-Fi.
iOS pairing issue / SSID not prefilled: iOS system settings
Tap “Wi-Fi”

Step 2

  • Tap the after the connected WiFi network. The connected WiFi network is indicated with a . In this example we use shyama_dp_2Ghz.

iOS pairing issue / SSID not prefilled: WiFi networks
Tap the connected Wi-Fi network

Step 3

  • Scroll down to Private Wi-Fi Address and disable it.
  • Also disable Limit IP Address Tracking.

These features frustrate the working of the eWeLink app.

iOS pairing issue / SSID not prefilled: advanced settings for connected WiFi network
Disable “Private Wi-Fi Address”
Disable “Limit IP Address Tracking”

Step 4

  • Check whether pairing works normally and whether you can visit the CMS pages at Profile > Help & feedback and Message > Guide / Explore.
  • If the app does still not work correctly you will need to send feedback to eWeLink. Since you can not do this in the preferred way (in-app) you will need to send an e-mail to . Please include:
    • Your name
    • Your accountname (either email address or phone number which you used to sign up for your eWeLink account)
    • Your mobile operating system (iOS) and version
    • A good description of the issue(s)
    • Steps you performed to try to solve the issue yourself (tip: if you followed the steps on this page then include the link to this page)
    • Screenshots that supports the description of the issue
< Previous Add devices to an eWeLink widget on the iOS Today View
Next > Error codes during pairing of a device

In case you think there is an error in a Knowledge Base article, there is something missing or when you have an idea for a new Knowledge Base article please contact us on our Contact form!

If you refer to an existing Knowledge Base article please include the link to the article involved!

Table of Contents